Eclipse修改Java编译环境

我们在使用Eclipse对Java程序编译的时候通常会JRE版本相关。有时编译出的Jar包版本太低了,不能调用,我们必须重新编译程序,生成对应的版本。例如JRE默认版本为1.7,我要修改为1.8。下面是基本流程:

1、Window -> Preferences 打开设置窗口

1

2、选择 Java -> Complier,打开编译设置界面

2

在上图中修改“Compiler compliance level:” 。我在区域1 将版本修改为1.8,同时区域2显示“当前版本为1.7。当使用1.8编译时,请确保对应的安装了对应的jre并且激活它”(When selecting 1.8 compliance, make sure to have a compatible JRE installed and activated. Configure…)。

点击区域2中的 Configure…,激活版本1.8。

3、切换新的版本

点击 Configure…,可以看到已经安装了两个版本的jre。默认是版本1.7。勾选“jre1.8.0_101”点击 确认完成修改。

3

如果在上图里没发现所要的版本,但是电脑已经安装该版本。可点击 “Add…”添加,如下图:

4

选择“Standard VM” -> Next>,之后如下图:

5

将JRE的安装路径填入“JRE home”中,并输入“JRE Name”,点击 “Finish”即可。之后返回上一级重新选择默认版本。

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s